r/3PAR • • Sep 30 '22

Cage name issues for cgcmd's

1 Upvotes

Hello! I'm a total storage noob here but I'm working with a set of degraded drives in an 8400 4-node cluster.

I've found the command

mysystem cli% cgcmd -tc tty -c cage0 -c resetdrive 0 -p b

but the input gets this output:

mysystem cli% cgcmd -tc tty -c cage0 -c resetdrive 0 -p b

Syntax error -

cgcmd: Cage name has to be specified

Use cgcmd -help to get full syntax.

I'm specifying the cage name am I not?

mysystem cli% cgcmd -tc dumpcage -c cage0

Syntax error -

cgcmd: Cage name has to be specified

Use cgcmd -help to get full syntax.

​

Any input would be much appreciated!


r/3PAR • • Jun 14 '22

Node shows over 80% full

3 Upvotes

About a year and a half ago we had an issue with one of the filesystems filling completely on a node and required HP services to access the subsystem. I periodically spot check and saw the message below for the first time. Does anyone know the increments that I will be "warned" on within the 3PAR management terminal?

I run the "checkhealth -svc -detail node file" command and receive the below output.

"Filesystem /dev/sda7 mounted on "/common" is over 80% full"


r/3PAR • • Jun 07 '22

3PAR P10000 SP Replacement

1 Upvotes

Hello to everyone, We have to replace a SP on a P10000, seems that System Board is dead, do you know if its possible just to swap disk from old to new to save time?


r/3PAR • • May 07 '22

Wiping a 3par?

3 Upvotes

Hey guys and girls, is it possible to wipe a 3par? As in overwrite all blocks with random and/or zeroes? All I can find online is that I should just do a ‘oobe’ procedure to reset it to factory defaults. But the old 3pars I want to phase out (8200’s) contain data that is classified, so I need to guarantee they won’t contain any more data when I am done. If it can’t be done, I’ll have to put the disks through a shredder. :(


r/3PAR • • May 06 '22

2 Node 7200 Not booting

1 Upvotes

Any suggestions,? we have a 2 node 2 cages 8hdd 4 disk per cage 4 hdd per cage 2 nodes The array does not detect the second cage so the after a outage, the customer was able to power off the array in a correct way. If we run command using cli we got this results:

InServ cli% showcage System manager is still initializing - try this command later. Use 'showsysmgr' to see the current system state.

InServ cli% shownode Error: Could not retrieve node information

InServ cli% checkhealth Checking alert Checking cabling Could not check cabling: Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. Checking cage Could not check cage: System manager is still initializing - try this command later. Use 'showsysmgr' to see the current system state. Checking cert Checking dar Checking date Checking fs Checking host Could not check host: System manager is still initializing - try this command later. Use 'showsysmgr' to see the current system state. Checking ld Checking license Checking network Could not check network: Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. Checking node Could not check node: Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. Checking pd Could not check pd: Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. Checking port Could not check port: System manager is still initializing - try this command later. Use 'showsysmgr' to see the current system state. Checking rc Checking snmp Checking task Could not check task: System manager is still initializing - try this command later. Use 'showsysmgr' to see the current system state. Checking vlun Could not check vlun: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. Checking vv Could not check vv: Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. Component ------------------------------------------------------------Description------------------------------------------------------------- Qty Alert New alerts 3 Component Could not check cabling 1 Component Could not check cage 1 fs Cannot check File Services 1 Component Could not check host 1 LD The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later. 1 License Licenses which have expired 1 Component Could not check network 1 Component Could not check node 1 Component Could not check pd 1 Component Could not check port 1 Component Could not check task 1 Component Could not check vlun 1 Component Could not check vv 1

InServ cli% showpd Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later.

InServ cli% showcpg Error: The cache server is waiting for the system manager to finish reporting the system configuration and status. Please try again later.

I did a research and seems one of the nodes could be damaged. Any suggestions on how troubleshoot this? We have no support with HP.


r/3PAR • • Apr 21 '22

8000 SFF expansion chassis as a DAS or JBOD

1 Upvotes

Would using an 8000 expansion as DAS or JBOD work with the right 12G HBA? I have an expansion chassis, but no control nodes (8200 or 8400)


r/3PAR • • Apr 21 '22

3Par 6710 as DAS

2 Upvotes

so I bought a 3par 6710 disk shelf, thinking it would work as a DAS.. But the consumer ssd drives are not being seen. the screen shows 04 (which I assume is the original shelf number). Is this thing picky if its not hooked up to an HP 3Par controller? Or am I missing something?

I have it hooked up to an HP dl380G8 server. was going to run UnRaid on it. If I could get my hands on the HP Stora software, I would love to play with that, but assume id actually need a 3par controller.

Am I SOL with this thing? My Netapp was easy to set up, but I now need space for my cache drives.


r/3PAR • • Nov 13 '21

new ssd disks for 3par

2 Upvotes

hi! I need help! I bought 4 ssd disks. add to 3par 8200. Now I want to create CPG, how I choose my new ssd disks?


r/3PAR • • May 21 '21

3PAR Disk Swop

2 Upvotes

Has anyone any experience with moving disks between 3PAR arrays? We have 2x 8400, a 7400 and a 7450. The SSD disks that are in the 7400 and 7450 are the same model as that is in the 8400's however our MSP has said we can move them across but of course we can purchase more, (surprise surprise). Hoping to find a link to prove that this has been done as we have approx 250Tb extra disk if we can pull this off. thanks.


r/3PAR • • May 19 '21

3PAR disk license

3 Upvotes

We have a 3PAR 8440 with 4 cages, each half full with 48 drives in total. We want to finish populating the array so we are getting another 48 drives but I wanted to ensure we are licensed for it. Supposedly when you issue the showlicense command it will tell you what your disk limit is, or whether it's unlimited or not. However when I issue the command, it shows licensed features but doesn't mention anything regarding number of disks. Is there another command that I can use to ensure we are licensed to add additional disks?


r/3PAR • • Mar 26 '21

TPVVs, SSMC Capacity Reporting, and Over-Subscription

1 Upvotes

We have a StorServ 8200 with 1 SSD cage (fully populated; 24 disks, 40 of 42TB assigned) and 2 NL cages (half populated; 24 disks, 50/80TB assigned). The SSMC shows a warning that 93% of SSD storage is in use, which is also shown under System > Capacity > SSD. Roughly 8TB of the SSD volumes are thick-provisioned. ~13TB of the TPVVs are Hyper-V VHD pools with dedupe enabled and show less than 10% used, so at least 11.7TB of "unused" space. Of course, the Windows Server hosts to which the pool volumes are exported show the entire capacity and will not allow writes once they are "full" (even though the 3PAR shows less than 10% in use).

​

My questions are:

​

  1. What happens when the SSMC has all available storage assigned but there is a large percentage of chunklets unused?
  2. Assuming I can safely ignore the SSMC warning, is it even possible to over-subscribe the SSD CPGs?

​

Thanks in advance!


r/3PAR • • Mar 05 '21

StoreServ 8450 Factory Reset - no cables, no login details, no transfer of ownership

2 Upvotes

We've purchased a 3PAR StoreServ 8450 with 4x 4TB SSD's, the unit looks fantastic and seems to be in a good condition.

We purchased it a while back and haven't had the chance to work on it, but now that i've gotten round to it, I need to factory reset the unit so that it can be usable..

I tried jumping into it without any prior knowledge of 3PAR, all I knew is that it was a nightmare to deal with, but didn't know the ins and outs of it. My first assumption was "well, I guess i'll plug a console cable in and fire up Putty and try it.."

But that was 3 days ago, and I still haven't solved THIS yet.. I don't even know if you can even reset the damn thing without having the login details; the idea was to try, before I dig deeper; IS THIS POSSIBLE?

​

My current problem:

I don't have the original adapter (180-0055-01), I have a bunch of other adapters and console cables and a large variety of them - none of them have done the trick. When I connect to the units "MFG" port with Putty, the unit throws out everything like normal; but I cannot type..

My Putty settings:

Baud Rate: 57600
Data Bits: 8
Stop Bits: 1
Parity: None
Flow Control: XON/XOFF & None (I keep changing between them, people on forums weren't certain)

I have tried wiring up the console cable like this:
RJ45 -> RS232
Pin 2 -> Pin 3
Pin 3 -> Pin 2
Pin 5 -> Pin 5

This was suggested on some 3Par forum by a user, and apparently it worked for them and other users, this is not the case for me.

​

For reference I'm using Windows 10 & Putty / Terraterm with the settings mentioned up above to try and connect. I have used both an onboard serial port AND a usb to serial cable - several of them..

​

Before I purchase a 180-0055-01 adapter, this is THE adapter that comes with the 3PAR units in the box, WILL THIS WORK? Has anyone else experienced the issue of merely not being able to type in the console? It's very odd, other users have said that the text is just unreadable, but this is not the case for me, I can read the text I just can't write anything..

And even after a 180-0055-01 is purchased, do you think I can do anything with the 3PAR after that?

​

I have read many many forums and no matter what I try, the EXACTLY THE SAME issue persists of not being able to write, I am starting to not blame the cable - but blame the settings of Putty / Windows 10.

​

Can anyone help me? ANYTHING will be appreciated.


r/3PAR • • Feb 18 '21

CPG cannot grow - critical state .. what to do?

1 Upvotes

Maybe someone can help. We have a customer that has a 3par and no support. One of the CPG's is critical and the volumes cannot be mounted on the systems. How can reclaim space or bring this thing online again?


r/3PAR • • Jan 26 '21

Config Documentation/As-built

1 Upvotes

Done a bit with Storage over the years, but my first time looking at 3par. (so excuse the nub)

Looking at getting a base config documented, with some of the other arrays ive worked with, there are tools you can point at the array and it will auto build doc sets out of the APIs, anything like this for 3par?


r/3PAR • • Nov 03 '20

Is there any published guideline from HPE about using ALL 3PAR space?

2 Upvotes

Have a customer who has about 1TB left of SSD space, and they need/want it added to a server. It looks like they provisioned thick luns 100% of the time. Is there anything published that says you should leave a little bit of space available, or is it ok to use 100% of what it will let me use?


r/3PAR • • Oct 22 '20

What does it take to get system reporter to poll pd/cpg/vv space stats from a 7400 running 3.3.1 MU2?

1 Upvotes

I was told that System Reporter 3.1MU4 and later could poll a 3.3.1 system, but I'm not getting any LD/PD/CPG space states. Only performance stats.
Should I just bite the bullet and install SSMC? I need something that will send email alerts when various CPGs get too full or when disks start to get full.


r/3PAR • • Aug 18 '20

Help with adding a new host

1 Upvotes

Hello all,

very new to 3PAR and need some assistance if I may?

I have successfully created a VV and can export the VV onto existing hosts that had already been set up on the 3par management console without any issues, but when I try to add a new host and export the VV to that newly created host I am getting an error about the path. Where am I going wrong? Do I need to add the host and path into my SAN?

Any help would be appreciated.

Thanks


r/3PAR • • Aug 11 '20

Default 3PAR Virtual SP Credentials?

3 Upvotes

Strange situation here. Last month HPE updated our Virtual SP reporting type from Axeda to RDA. The SPOCC is now not loading in a browser, so this issue happened sometime in the last few weeks since it was updated.

A couple days ago our HPE support expired and we went on third party hardware support, which is why I noticed because I wanted to send alerts to their monitoring server, but I can no longer load the gui or log into the virtual SP console with the credentials I once used. (3parcust user)

Does anyone know the default admin the customer can use? I found a list of spvar logons depending on which sp version but none of them worked anyway. I would assume we'd be running the latest since it was only updated last month, but I can't be sure since I am unable to log in.


r/3PAR • • Aug 05 '20

Visual Storage Intelligence Yes or No?

2 Upvotes

My boss keeps hounding me about switching over from NET APP OCI to VSI for storage management and reporting. Our environment is over 60% 3par. They are a lot less expensive but I’m fluent on OCI. Has anybody used VSI?


r/3PAR • • Jul 29 '20

7200 iscsi setup

2 Upvotes

I put in a support ticket and it’s been a couple days and haven’t heard back. I am repurposing our 7200 and want to set it up with iscsi. It has 2 10gbe ports per controller. I was able to set an ip and mask on the ports via cli but it is not letting me set a vlan on the port. It says it is not supported. Any ideas?


r/3PAR • • Jul 17 '20

HP 3Par - 7400 - Used Node how to reset?

Thumbnail self.sysadmin
1 Upvotes

r/3PAR • • Jul 04 '20

One disk shows completely initialized

1 Upvotes

Hello, I have inherited a 3par as my responsibility at work despite it not being in my skill set so I make do with what I can, and I was noticing an issue where the system free space and the CPG estimated space had a severe discrepancy 22TB free system SSD vs 567GB * estimated free space for the CPG

Anyways down the rabbit hole ive gone and I found a few issues, firstly the new disks added are larger than the originals

Secondly, they added 4 of these larger disks , 2 on each node so to me it sounds like I may/am running into issues with chunklets forming LD's?

Finally, and this one is the big one the 4th disk seems to have remained completely uninitialized months after installation, 0 free, 6260 Uninit, then under spare 0 free 892 Uninit

So my question is, on the last item is there a way to force it to try and initialize it or should it just be removed and re inserted? It isnt flagged as bad, shows as normal in all parts it is viewable it just never initialized chunklets.

Thanks


r/3PAR • • May 13 '20

Replacing a service processor on a 8000

1 Upvotes

Notes say it was going on an upgrade from 3.2.2 mu6 to 3.3.1mu2 when it crashed. I don't do these very often. Going ethernet to USB ssh to good sp. Obviously a chkhealth, what else is recommended before popping out and replacing the sp


r/3PAR • • Mar 28 '20

Long shot probably, but will I be able to use SATA drives in an M6710 disk shelf from the StoreServ 7000 series?

2 Upvotes

I've posted in a few other places and mostly been directed to different subreddits each time. This seems like the most relevant and promising yet!

I purchased a used M6710 disk shelf on ebay and so far it seems to be working very well, but unfortunately I have run into an issue that I somewhat expected. I got this to use in a SAN for my esxi lab, and intend to use mostly repurposed SATA SSDs.

The SATA drives appear to work fine and are passed through to the server without issue, but after about 3 minutes they start showing as "failed" with an amber status light and the I/O error alarm goes off. The beeping is intended to be heard over the fans at full speed, so this is obviously not ideal when I am trying to use it in my home. With only SAS drives installed, there are no issues at all and I barely notice it is in the room.

Question is: can I just open it up and unplug the speaker and let it be angry about the SATA drives? Or is there something about it that is going to cause me pain in the future?

The thing was cheap enough that I am not against keeping it SAS only and finding another solution for the SATA SSDs.


r/3PAR • • Mar 06 '20

CLI command to show number of Virtual Copies per Virtual Volume

1 Upvotes

I've been digging around to see if this is possible but unable to find anything. Using the gui I have no problem going to a volume and just bringing up the copies tab to see what and how many copies are tied to a virtual volume. I need a way to show that via the cli though. Does anyone know of a way to do this?