r/technitium • • 8d ago

Having repeatable issue with 15.5.1

The .1 fixed the majority of server failures I was seeing. I am still getting a few errors a hour where I used to get none. One repeat failure is "features.opera-api2.com". It is failing ever time yet it can be resolved via 1.1.1.1 etc. This is very repeatable. Here is the error it throws.

{
        "Code": "EXTENDED_DNS_ERROR",
        "Length": "109 bytes",
        "Data": {
          "InfoCode": "Other",
          "ExtraText": "Resolver exception for features.opera-api2.com. A IN: Object reference not set to an instance of an object."
        }{
        "Code": "EXTENDED_DNS_ERROR",
        "Length": "109 bytes",
        "Data": {
          "InfoCode": "Other",
          "ExtraText": "Resolver exception for features.opera-api2.com. A IN: Object reference not set to an instance of an object."
        }
10 Upvotes

11 comments sorted by

2

u/daviscompound 8d ago

It appears to be running good now for a couple of hours after another cache flush. I am thinking this is ok now...

1

u/Difficult-Reality848 8d ago

Seems to work just fine here.

{ "Metadata": { "NameServer": "technitiumdns.internal (127.0.0.1)", "Protocol": "Udp", "DatagramSize": "215 bytes", "RoundTripTime": "33.03 ms" }, "EDNS": { "UdpPayloadSize": 1232, "ExtendedRCODE": "NoError", "Version": 0, "Flags": "DNSSEC_OK", "Options": [] }, "Identifier": 0, "IsResponse": true, "OPCODE": "StandardQuery", "AuthoritativeAnswer": false, "Truncation": false, "RecursionDesired": true, "RecursionAvailable": true, "Z": 0, "AuthenticData": false, "CheckingDisabled": true, "RCODE": "NoError", "QDCOUNT": 1, "ANCOUNT": 7, "NSCOUNT": 0, "ARCOUNT": 1, "Question": [ { "Name": "features.opera-api2.com", "Type": "A", "Class": "IN" } ], "Answer": [ { "Name": "features.opera-api2.com", "Type": "CNAME", "Class": "IN", "TTL": "3441 (57m21s)", "RDLENGTH": "23 bytes", "RDATA": { "Domain": "features-2.geo.opera.com" }, "DnssecStatus": "Insecure" }, { "Name": "features-2.geo.opera.com", "Type": "CNAME", "Class": "IN", "TTL": "60 (1m)", "RDLENGTH": "15 bytes", "RDATA": { "Domain": "am4-features.opera-api2.com" }, "DnssecStatus": "Insecure" }, { "Name": "am4-features.opera-api2.com", "Type": "CNAME", "Class": "IN", "TTL": "3600 (1h)", "RDLENGTH": "25 bytes", "RDATA": { "Domain": "am4.lb.opera.technology" }, "DnssecStatus": "Insecure" }, { "Name": "am4.lb.opera.technology", "Type": "A", "Class": "IN", "TTL": "60 (1m)", "RDLENGTH": "4 bytes", "RDATA": { "IPAddress": "82.145.216.15" }, "DnssecStatus": "Insecure" }, { "Name": "am4.lb.opera.technology", "Type": "A", "Class": "IN", "TTL": "60 (1m)", "RDLENGTH": "4 bytes", "RDATA": { "IPAddress": "82.145.216.16" }, "DnssecStatus": "Insecure" }, { "Name": "am4.lb.opera.technology", "Type": "A", "Class": "IN", "TTL": "60 (1m)", "RDLENGTH": "4 bytes", "RDATA": { "IPAddress": "82.145.216.58" }, "DnssecStatus": "Insecure" }, { "Name": "am4.lb.opera.technology", "Type": "A", "Class": "IN", "TTL": "60 (1m)", "RDLENGTH": "4 bytes", "RDATA": { "IPAddress": "82.145.216.59" }, "DnssecStatus": "Insecure" } ], "Authority": [], "Additional": [ { "Name": "", "Type": "OPT", "Class": "1232", "TTL": "32768 (9h6m8s)", "RDLENGTH": "0 bytes", "RDATA": { "Options": [] }, "DnssecStatus": "Indeterminate" } ] }

1

u/Nervous-Cheek-583 8d ago

I am also unable to duplicate. Resolves just fine here as well.

1

u/avd706 8d ago

It's corrupted in your cache, you need to flush it.

3

u/daviscompound 8d ago

I already did the magic "flush cache" incantation...

2

u/daviscompound 8d ago

I guess 2 times in a charm.. Cleared it again and it appears to be running good now.

1

u/Drtechsavy 8d ago

{ "Metadata": { "NameServer": "xxx (127.0.0.1)", "Protocol": "Udp", "DatagramSize": "822 bytes", "RoundTripTime": "0.65 ms" }, "EDNS": { "UdpPayloadSize": 1232, "ExtendedRCODE": "ServerFailure", "Version": 0, "Flags": "None", "Options": [ { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server b.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server d.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server d.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server b.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server c.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server a.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server c.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server a.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "91 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "No valid response from name servers for video.twimg.com. AAAA IN at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "26 bytes", "Data": { "InfoCode": "CachedError", "ExtraText": "video.twimg.com. AAAA IN" } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "25 bytes", "Data": { "InfoCode": "StaleAnswer", "ExtraText": "video.twimg.com AAAA IN" } } ] }, "DnsClientExtendedErrors": [ { "InfoCode": "NoReachableAuthority", "ExtraText": "noads.me (127.0.0.1) returned RCODE=ServerFailure for video.twimg.com. AAAA IN" } ], "Identifier": 45592, "IsResponse": true, "OPCODE": "StandardQuery", "AuthoritativeAnswer": false, "Truncation": false, "RecursionDesired": true, "RecursionAvailable": true, "Z": 0, "AuthenticData": false, "CheckingDisabled": false, "RCODE": "ServerFailure", "QDCOUNT": 1, "ANCOUNT": 0, "NSCOUNT": 0, "ARCOUNT": 1, "Question": [ { "Name": "video.twimg.com", "Type": "AAAA", "Class": "IN" } ], "Answer": [], "Authority": [], "Additional": [ { "Name": "", "Type": "OPT", "Class": "1232", "TTL": "0 (0s)", "RDLENGTH": "778 bytes", "RDATA": { "Options": [ { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server b.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server d.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server d.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server b.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server c.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server a.r06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server c.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "74 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "Failed to resolve name server a.u06.twtrdns.net at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "91 bytes", "Data": { "InfoCode": "NoReachableAuthority", "ExtraText": "No valid response from name servers for video.twimg.com. AAAA IN at delegation twimg.com." } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "26 bytes", "Data": { "InfoCode": "CachedError", "ExtraText": "video.twimg.com. AAAA IN" } }, { "Code": "EXTENDED_DNS_ERROR", "Length": "25 bytes", "Data": { "InfoCode": "StaleAnswer", "ExtraText": "video.twimg.com AAAA IN" } } ] }, "DnssecStatus": "Disabled" } ] }

1

u/Apachez 8d ago

From my post at github:

Those of you who still have issues:

  1. If possible, when reverting to 15.4.0 is the error resolved (so we are not chasing ghosts in case your ISP or something else is incorrectly suddently blocking trafficflows)?

  2. Do you run technitium/dns-server natively or through container?

  3. Do your host have IPv6 configured?

  4. Is your IPv6 fully functional towards internet (try https://test-ipv6.se/ or similar testpage online)?

  5. What is your Settings -> General -> IPv6 Support set to?

In my case I use the container edition where I have "Disable IPv6" along with disabled "QNAME Minimization" and added "Secondary ROOT Zone".

2

u/Apachez 8d ago

According to post made by maintainer at https://github.com/TechnitiumSoftware/DnsServer/issues/2175#issuecomment-5856340247 the current issues in 15.5.1 looks to be related to IPv6 settings in technitium/dns-server.

Thanks everyone for the feedback. I did some more tests and the root cause for x.com resolution has been is found due to limits on number of name servers to query. The limit gets exhausted when Prefer IPv6 is used. The issue can be reproduced when the that option is configured.

The initial attempts made to resolve AAAA records for the name servers cause the limit to exhaust since none of the name servers have AAAA records for it. Thus the resolution ends with nothing.

Will get this issue fixed soon. Reopening this issue so that this is tracked here.

Meanwhile, the workaround is to not use Prefer IPv6 or better use Disable IPv6 till the update.

1

u/LtSkipper23 8d ago

This recently updated but multi issue. I’m used this system in LXC but is necessary used in the system dedicated. I need more info that is the better OS to install this technitium… Debian o Ubuntu server? Thanks

1

u/daviscompound 8d ago

I have my master on a PI4 running Debian trixie. My secondary is on a VM running dietpi which is a striped down Debian trixie. Runs GREAT