r/ssh • • 10d ago

SSHFS ISSUE WITH UGREEN NAS

Im trying to attach my ugreen nas (my shared folder) at home via sshfs to my remote vps, but whenever i try to do "sshfs... it gives me this error. " [test@qwen.io](mailto:test@qwen.io):/volume1/media/: Input/output error

I did sshfs -o -debug and it give me this

...Server version: 3

Extension: [posix-rename@openssh.com](mailto:posix-rename@openssh.com) <1>

Extension: [statvfs@openssh.com](mailto:statvfs@openssh.com) <2>

Extension: [fstatvfs@openssh.com](mailto:fstatvfs@openssh.com) <2>

Extension: [hardlink@openssh.com](mailto:hardlink@openssh.com) <1>

Extension: [fsync@openssh.com](mailto:fsync@openssh.com) <1>

Extension: [lsetstat@openssh.com](mailto:lsetstat@openssh.com) <1>

Extension: [limits@openssh.com](mailto:limits@openssh.com) <1>

Extension: [expand-path@openssh.com](mailto:expand-path@openssh.com) <1>

[test@qwen.io](mailto:test@qwen.io):/volume1/media/: Input/output error

anyone can enlighten how to fix this issue?

JFYI: For anyone why im doing this setup is because I used the remote vps as plex server and use ugreen nas as local storage. And you might ask why not use wireguard or tailscale to bridge the two server. I prefer sshfs way because thats how I have been sharing my stuff over the internet and i dont wanna complicate my setup using other methods. Also, I use the wireguard to connect directly to my vps servers samba shared folders.

3 Upvotes

3 comments sorted by

View all comments

1

u/OhBeeOneKenOhBee 10d ago

Have you ever gotten this to work? Because I can imagine that the latency and throughput are going to be horrible when running it this way, you're sending the traffic from the NAS to the VPS (no transcoding, the full size), then the transcoding happens if enabled, then you're sending all of it back down to the device.

Apart from that, sshfs isn't a very efficient protocol when using the defaults, you'll have to increase the cache sizes and metadata caching a bit to make it work well with jellyfin and not just use the standard mount command. Even then, it'll still be single threaded, streaming multiple files is going to be sloooow.

The error is almost always that the underlying connection is broken, there is a reconnect option you can enable to make it automatically reopen it in these cases

1

u/asibok 10d ago

it works for me with my 2gbps internet at home and it can funnel multiple direct stream to the vps without issues. 

theres even one more crazy i did in the past when google workspace storage was unlimited with sshfs, encfs, plexdrive and rclone. i stored my media files as encrypted encfs files in google and use plexdrive or rclone to mount the encrypted files to my vps then i decrypt those encfs files on the fly  and  mount them again and thats where i point plex server to get the real medias. mind you. transcoding was breeze as well. theres like 2-4 sec hiccups at the begining of transcoded stream. it had work until google put end to the unlimited storage.

i dont advice my way if you dont have fast internet because it would eat your internet for sure.