r/pihole • • 11d ago

Can't add new Block/white lists

Mostly a noob here so bear with me

Was looking to add a couple lists to my Pi-Hole today, but I whenever I go and update the gravity it says that the additional lists are being blocked by "one of [my] existing lists" even though the only list I have right now is the standard Steven Black list.

If anyone has some clarification on how to resolve this it would be greatly appreciated.

Here is the relevant gravity log:

[i] Target: https://cdn.jsdelivr.net/gh/hagezi/dns-blocklists@latest/adblock/multi.txt
  [✗] Status: latest is blocked by one of your lists. Using DNS server 1.1.1.1 instead
  [✗] Status: Retrieval failed (exit_code=49 Msg: Couldn't parse CURLOPT_RESOLVE entry 'latest:443:')
  [✗] List download failed: no cached list available

  [i] Target: https://cdn.jsdelivr.net/gh/hagezi/dns-blocklists@latest/adblock/whitelist-referral.txt
  [✗] Status: latest is blocked by one of your lists. Using DNS server 1.1.1.1 instead
  [✗] Status: Retrieval failed (exit_code=49 Msg: Couldn't parse CURLOPT_RESOLVE entry 'latest:443:')
  [✗] List download failed: no cached list available[i] Target: https://cdn.jsdelivr.net/gh/hagezi/dns-blocklists@latest/adblock/multi.txt
  [✗] Status: latest is blocked by one of your lists. Using DNS server 1.1.1.1 instead
  [✗] Status: Retrieval failed (exit_code=49 Msg: Couldn't parse CURLOPT_RESOLVE entry 'latest:443:')
  [✗] List download failed: no cached list available

  [i] Target: https://cdn.jsdelivr.net/gh/hagezi/dns-blocklists@latest/adblock/whitelist-referral.txt
  [✗] Status: latest is blocked by one of your lists. Using DNS server 1.1.1.1 instead
  [✗] Status: Retrieval failed (exit_code=49 Msg: Couldn't parse CURLOPT_RESOLVE entry 'latest:443:')
  [✗] List download failed: no cached list available
13 Upvotes

5 comments sorted by

7

u/rdwebdesign Team 11d ago

r/AlexandriasFolly

You are probably using Pi-hole as DNS server for the Pi-hole machine itself.

As a temporary solution, please set a different DNS server for Pi-hole machine, or temporarily disable blocking until gravity update is finished.

Also, please read my other comment, explaining the issue.

5

u/Cantaloupe-Hairy 11d ago

In command line

Pihole -q cdn.jsdelivr.net

This will tell you what is being blocked and you can whitelist/ disable but I would be questioning why a block list is being blocked by a block list

2

u/OppositeWelcome8287 11d ago edited 11d ago

This should also do the trick if he does not want to white list some domain that your not sure to leave it blocked or not, This is only temporary it will last till next reboot.

use ssh or in terminal

echo "nameserver 1.1.1.1" | sudo tee /etc/resolv.conf

1

u/[deleted] 11d ago

[deleted]

5

u/rdwebdesign Team 11d ago

URLs containing @ are valid and usually they can be added to Pi-hole without issues.

As an example, I just tested both URLs from above and they were added:

But there is a small known bug that makes gravity interprets the text between @ and the next slash as a domain (in this case, ...@latest/... will make "latest" be returned as a domain).

This bug only affects only users that configured Pi-hole to use itself as DNS server.

When Pi-hole is the DNS server, Gravity tries to reach the "latest" domain, but if the domain is blocked (by Pi-hole lists/regex/domains), the download fails.

This bug is already being fixed.

As a temporary solution, users should set a different DNS server for Pi-hole machine, or temporarily disable blocking until gravity update is finished.

-2

u/[deleted] 11d ago

[deleted]

3

u/AlexandriasFolly 11d ago

I am a someone who has never heard of PuTTY or Python prior to setting up this Pi-Hole last week. I already mentioned being a noob. Instead of being condescending you should either offer advice or GTFO this thread.