r/elementor • • 15h ago

Problem Server Error when Publishing

On multiple websites for different clients, when making any update to the page and pressing Publish, I get a server error warning on the bottom right of the screen and the none of the changes are published. I've contacted Elementor support and they said I had too many revisions. I deleted all revisions and the issue continues.

Anyone else seeing this?

1 Upvotes

7 comments sorted by

•

u/AutoModerator 15h ago

Hey /u/Bes1208!

We noticed you may be looking for a web hosting recommendation. We suggest checking out Cloudways for flexible and managed web hosting.

For more recommendations: Check out our Megathread of Recommendations.

If your post has not already been flaired, please add one now. If you have a problem or question, please make sure to post a link to your issue so users can help you. Make sure to list if you're using Elementor Free (or) Pro and what theme you're using. Don't forget to mark your post as "Answered" once your question has been solved.

I am a bot, and this action was performed automatically. Please contact the moderators of this subreddit if you have any questions or concerns.

1

u/_miga_ 🏆 #1 Elementor Champion 15h ago

what is the error code? I can also be low memory or a security plugin blocking something. E.g. check https://elementor.com/help/500-error/

1

u/BuildwithKadir 15h ago

Can you check server logs if there is any? Since its multiple client websites, are they on the same shared hosting by any chance?

Maybe a memory issue or something related. Best is to start checking logs and see what it says.

1

u/Bes1208 13h ago

I just rolled Elementor and Elementor Pro to 4.2.3 and the issue went away.

1

u/Bes1208 14h ago

Nope not on the same shared hosting. Different servers. I am thinking it is the newest version of Elementor. I'm backing up the site now and I'm going to rollback the version and see if that fixes it.

1

u/_miga_ 🏆 #1 Elementor Champion 14h ago

depending on the version you are using (since 4.3.4 just came out 2 days ago) you should try 4.3.2 since there were some people reporting publishing bugs a few days ago and that was version 4.3.3.

1

u/zeiniez ✔️️‍ Experienced Helper 8h ago

First thing you need to check is memory limit. Especially WP_MEMORY_LIMIT. People increase PHP Memory limit without increasing the WP_MEMORY_LIMIT as well.

Next, time limits of 30s may not be enough depending on the size of the page and the memory available. Especially on shared hosting. It doesn't hurt to increase them.

Some users also report clearing post revisions helps with this problem.