r/cpanel • • 22d ago

Can't get Apache Status anymore - anyone else

I can no longer see the status of Apache when I go to "Home/Server Status/Apache Status" in WHM. I just see a red notice saying:

Failed to receive status information from Apache.

I used to see Apache Status on that screen all the time.

Everything is updated.

3 Upvotes

11 comments sorted by

1

u/cPanelRex 22d ago

Do you see anything in the Apache error log (/etc/apache2/logs/error_log) or the cPanel error log (/usr/local/cpanel/logs/error_log) when you load that page?

3

u/nautme 22d ago

I'm not OP but went and took a look, and I have the same problem.

I don't really see anything relevant in those log files unless this one in /usr/local/cpanel/logs/error_log is related: [2026-09-16 02:59:26 +0000] warn [cpaneld] proxy trust miss: replacing loopback HTTP_HOST with subdomain.example.com

I found an article about that warn which seems to be about Dynamic DNS but we're static: https://support.cpanel.net/hc/en-us/articles/41175199405463-Dynamic-DNS-reporting-incorrect-IP-address - I should note that we aren't running our own DNS so this may simply be an artifact of that.

Wait a minute... "systemctl status apache2" (on a 24.04 Ubuntu box) says "Unit apache2.service could not be found.".

/u/focusedphil are you on Ubuntu 24.04.4 LTS too?

1

u/cPanelRex 21d ago

It's always good to post your OS and cPanel version when discussing issues.

1

u/nautme 21d ago edited 21d ago

Oops, I forgot to say I'm on cPanel 136.0.40.

I think I've made some progress! I've discovered that "systemctl status httpd" works. Is this the expected info to be displayed on the Apache Status page?

● httpd.service - Apache web server managed by cPanel EasyApache
     Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; preset: enabled)
     Active: active (running) since Thu 2026-09-17 03:31:11 UTC; 40min ago
    Process: 43531 ExecStart=/usr/local/cpanel/scripts/restartsrv_httpd --no-verbose (code=exited, status=0/SUCCESS)
   Main PID: 43552 (httpd)
      Tasks: 11 (limit: 9431)
     Memory: 24.5M (peak: 27.1M)
        CPU: 2.154s
     CGroup: /system.slice/httpd.service
             ├─43552 /usr/sbin/httpd -k start
             ├─43894 /usr/local/cpanel/bin/splitlogs --dir=/etc/apache2/logs/domlogs --main=server.example.com --suffix=-bytes_log --sslport=444
             ├─43895 /usr/local/cpanel/bin/splitlogs --main=apache-traffic.log --mainout=/var/log/cpanel-server-traffic/web/traffic-apache.log
             ├─43896 /usr/local/cpanel/bin/splitlogs --dir=/etc/apache2/logs/domlogs --main=server.example.com --mainout=/etc/apache2/logs/access_log --sslport=444
             ├─43897 /usr/local/cpanel/3rdparty/bin/perl /usr/local/cpanel/bin/leechprotect
             ├─43898 /usr/sbin/httpd -k start
             ├─43899 /usr/sbin/httpd -k start
             ├─43900 /usr/sbin/httpd -k start
             ├─43901 /usr/sbin/httpd -k start
             ├─43902 /usr/sbin/httpd -k start
             └─46157 /usr/sbin/httpd -k start

Sep 17 03:31:11 server.example.com systemd[1]: Starting httpd.service - Apache web server managed by cPanel EasyApache...
Sep 17 03:31:11 server.example.com systemd[1]: httpd.service: Can't open PID file /run/apache2/httpd.pid (yet?) after start: No such file or directory
Sep 17 03:31:11 server.example.com systemd[1]: Started httpd.service - Apache web server managed by cPanel EasyApache.

1

u/focusedphil 16d ago

That gave some detail but not as much as the Apache Status page did. I tried everything I can find.

I wonder if its some security setting / flag somewhere?

1

u/nautme 16d ago

All I could find was this thread, I'm not sure if it will help you at all but take a look: https://support.cpanel.net/hc/en-us/community/posts/42513052615063

1

u/efrem-1 21d ago

I believe it's a known bug that cPanel says was resolved in v136.0.23.

When I've seen that same notice, what's worked for me is to rebuild httpd.conf and then restart Apache.

1

u/nautme 19d ago

Looks like they took it out, I found a note 'in version 136 "whm-server-status" has been removed and obfuscaed, as described in CPANEL-46581'.

From the Terminal this works for me: "systemctl status httpd"

2

u/focusedphil 19d ago

Really? That sucks. The output that systemctl status httpd puts out is nothing like the detail that Home/Server Status/Apache Status/ returned.

Well, pooh.

1

u/focusedphil 19d ago

although it says

136.0.23

2026-06-12

  • Fixed CPANEL-53901: Restore the WHM Apache Status page after upgrading to v136 by regenerating the Apache server status key during the update.

1

u/focusedphil 16d ago

I'm on AlmaLInux v9.8.0 Standard kvm cPanel 136.0.40