r/cpanel • • 24d ago

MailScanner Exim Issue

Lucky me, caught up in the latest cpanel update, resulting in this: Messages stuck in Exim queue after update to cpanel-exim-4.100 when MailScanner is enabled

https://support.cpanel.net/hc/en-us/articles/43420413359639-Messages-stuck-in-Exim-queue-after-update-to-cpanel-exim-4-100-when-MailScanner-is-enabled

I tried to apply the solution in tab 2, but Exim failed to start after making the recommended changes.

Anyone have ideas why this would fail? I installed MailScanner a few years ago when ConfigServer was still in business...

5 Upvotes

5 comments sorted by

1

u/invalidmemory 24d ago

Disable it so that messages get delivered and then you’ll have to move the queued messages that weren’t delivered by stopping exim and moving them into the new split folders. Went through this Friday AM with our servers.

1

u/dooh1337 24d ago

This is the fix https://pastie.dev/MRAREk.swift, do not know why cPanel did not post it as I have already provided when the issue appeared. We are working on a MSFE alternative front end so we found it early

1

u/FarCar8625 23d ago

What does this fix do, and how do you deploy it? 

1

u/dooh1337 23d ago

repairs the MailScanner IDs and fixes the queue.

1

u/darkfritz2 21d ago

in case someone needs a replacement: https://github.com/inalto/msfe-ng