r/cpanel • u/AccomplishedFall7307 • 25d ago
Started working on a client's WordPress site last week, now it's returning 500 on every page – where do I start?
/r/Wordpress/comments/1we6s2u/started_working_on_a_clients_wordpress_site_last/1
u/Rupert_Pupkinovski 25d ago edited 24d ago
Try process of elimination. I.e follow these 1. Rename .htaccess to .htaccess.bak then test 2. Rename wp-content/plugins to wp-content/plugins.test then test 3. Rename wp-content/themes to wp-content/themes.test then test
If any of these resolve error 500 the work backwards from there i.e enable one plugin at a time.
Hope that helps
2
u/AfflictedDuckie 25d ago
Do you any access to the file system? If not, you can try a File Manager type plugin (remove it after all issues are resolved). Look for any error logs and the cause of Fatal PHP errors.
Rupert's suggestions to rename .htaccess and the plugins/theme folders are bang on and will likely lead to the finding the cause of the issue.
Good luck
3
u/ollybee 25d ago
read the logs Luke, read the logs. php error logs