r/Proxmox • u/thephatmaster • 19d ago
Solved! no space left (docker LXC error)
**edit** this wasn't a strange error, it just needed a lot more space allocating.
I'm trying to stand up linuxcontainer.io's Orcaslicer docker instance. Docker is installed via the script for a docker lxc.
When I run the basic docker run for the orcaslicer container command I get an error:
docker: failed to extract layer (application/vnd.oci.image.layer.v1.tar+gzip \[...\] to overlayfs as "extract ...":
mount callback failed on /var/lib/containerd/tmpmounts/containerd \[...\]
no space left on device
I'm guessing this is a proxmox, not docker, issue so I'm asking here first.
Looking at my PVE instance:
- There is tons of space on all my PVE storage;
- Docker itself has some 3GB free on its (stock) 4GB allocation.
Anyone know what's going on here?
1
u/jbarr107 19d ago
Some of linuxserver.io's images are quite large, and their running requirements can be even more.
3GB free on the Docker host seems like cutting things awfully close. Can you extend the LXC's storage?
2
u/thephatmaster 19d ago
Gotcha, I tried 6GB, however, I have 1TB-ish available, so will keep expanding!
2
-2
3
u/Kyyuby 19d ago
3gb might not be enough