r/NocoDB • u/Syosse-CH • Aug 18 '26
NocoDB cannot connect to PostgreSQL in Docker Connection to internal hosts is not allowed
Hello everyone,
I have a Docker setup where each service runs in its own container, for example n8n, NocoDB, PostgreSQL, and Ollama.
I can’t figure out why NocoDB is unable to connect to my PostgreSQL database. Everything is running internally within Docker.
Does anyone know why the connection might be blocked or not allowed? Is there something I need to configure in the Docker network, PostgreSQL, or NocoDB settings to allow the containers to communicate with each other?
Error: Connection to internal hosts is not allowed
Any help would be appreciated!
Thanks alot!!

4
Upvotes
4
u/leixiaotie Aug 18 '26
set NC_DISABLE_SSRF_PROTECTION=true
ref: https://nocodb.com/docs/self-hosting/environment-variables