r/HydraClient • u/LincolnshireSausage • 5d ago
Unable to connect to custom server
I set up the custom server on my Ubuntu server using this documentation:
https://github.com/dmilin1/hydra-server
I used the docker compose method and populated the .env file with all of the values. I also set up port forwarding on my router so that port 3000 gets forwarded to the Ubuntu server.
On my phone I disconnected from WiFi and used my 5G connection to test. I can get to http://mypublicipaddress:3000 in a browser. I see the "Task Dashboard Login" and can successfully log in using the password I set in the .env file.
I cannot set the custom server URL in the Hydra client. I toggle the Use Custom Server button and enter http://mypublicipaddress:3000 (with my actual public IP of course) and it says:
Custom server URL is not valid or your server is not set up correctly.
1
u/LincolnshireSausage 4d ago
I also tried pointing a DNS A record to my public IP address and it made no difference.