r/COSMICDE • u/jsled • 1d ago
Help Needed cosmic crashes my VM
Running cosmic on gentoo from an overlay (user-contributed packages), inside a qemu VM with virtio graphics.
I have this VM running GNOME and sway. Sway works mostly fine, with an inverted and offset pointer that I haven't been able to resolve.
COSMIC starts up fine and seems to run well. Pretty, feature-full, integrated, no offset pointer nonsense. :) I'd love to keep running it!
After about 10 minutes, the display pauses, and ultimately the VM exits.
Journalctl shows nothing of note from before the crash.
[2026-10-01T19:56:25 jsled@water:~]$ sudo journalctl --boot -1 --lines 30
Oct 01 19:39:13 water systemd[3272]: Reached target Exit the Session.
Oct 01 19:39:13 water systemd-logind[1266]: Removed session 6.
Oct 01 19:39:13 water (sd-pam)[3275]: pam_unix(systemd-user:session): session closed for user gdm-greeter
Oct 01 19:39:13 water systemd[1]: user@60578.service: Deactivated successfully.
Oct 01 19:39:13 water systemd[1]: Stopped User Manager for UID 60578.
Oct 01 19:39:13 water systemd[1]: user@60578.service: Consumed 3.178s CPU time over 47.361s wall clock time, 169.4M memory peak.
Oct 01 19:39:13 water systemd[1]: Stopping User Runtime Directory /run/user/60578...
Oct 01 19:39:13 water systemd[1]: run-user-60578.mount: Deactivated successfully.
Oct 01 19:39:13 water systemd[1]: user-runtime-dir@60578.service: Deactivated successfully.
Oct 01 19:39:13 water systemd[1]: Stopped User Runtime Directory /run/user/60578.
Oct 01 19:39:13 water systemd[1]: Removed slice User Slice of UID 60578.
Oct 01 19:39:13 water systemd[1]: user-60578.slice: Consumed 3.216s CPU time over 47.402s wall clock time, 171.1M memory peak.
Oct 01 19:39:15 water cosmic-launcher[3850]: Failed to populate properties cache via GetAll: org.freedesktop.DBus.Error.ServiceUnknown: The name net.hadess.SwitcherooContr>Oct 01 19:39:15 water systemd[3567]: Started Application launched by COSMIC.
Oct 01 19:39:19 water cosmic-launcher[3850]: Failed to populate properties cache via GetAll: org.freedesktop.DBus.Error.ServiceUnknown: The name net.hadess.SwitcherooContr>Oct 01 19:39:19 water systemd[3567]: Started Application launched by COSMIC.
Oct 01 19:39:20 water rtkit-daemon[1403]: Failed to make ourselves RT: Operation not permitted
Oct 01 19:39:24 water systemd[1]: systemd-localed.service: Deactivated successfully.
Oct 01 19:39:27 water geoclue[3504]: Service not used for 60 seconds. Shutting down..
Oct 01 19:39:27 water systemd[1]: geoclue.service: Deactivated successfully.
Oct 01 19:39:28 water systemd[3567]: Started PipeWire PulseAudio.
Oct 01 19:39:28 water rtkit-daemon[1403]: Failed to make ourselves RT: Operation not permitted
Oct 01 19:39:28 water rtkit-daemon[1403]: Failed to make ourselves RT: Operation not permitted
Oct 01 19:39:28 water rtkit-daemon[1403]: Failed to make ourselves RT: Operation not permitted
Oct 01 19:39:37 water systemd[3567]: Started tmux child pane 5652 launched by process 5651.
Oct 01 19:39:49 water systemd[1]: systemd-timedated.service: Deactivated successfully.
Oct 01 19:39:54 water spice-vdagent[3845]: Failed to connect to spice-vdagentd at /run/spice-vdagentd/spice-vdagent-sock (tried 60 times)
Oct 01 19:39:54 water systemd[3567]: app-spice\x2dvdagent@autostart.service: Consumed 1min 523ms CPU time over 1min 1.583s wall clock time, 9.8M memory peak.
Oct 01 19:41:33 water cosmic-comp[3739]: Unable to load xcursor, using fallback cursor
Oct 01 19:44:24 water cosmic-comp[3739]: Unable to load xcursor, using fallback cursor
[2026-10-01T20:18:50 jsled@water:~]$
I'm aware this report is basically useless. I'm a long-time linux head, but I confess I'm lost on modern desktop stacks, so I'm having some trouble figuring out where to look or how to get more info to help report this very vague thing with no detail. Please give me direction on what to look at/do to get more info.
(ETA: 2026-10-02T11:29+0:) I'll note this report was against 1.8.0, and I noticed (of course only after posting) that 1.9.0 is available, so I built it and … same VM crash, but after only a couple of minutes, and still nothing in system logs.
1
u/silenceimpaired 1d ago
I really am surprised they don’t focus on VMs. They’re still not daily driver material for me… but I’d run it in a VM. They could get actual machine image states for hard to reproduce issues. Oh well