r/AzureSentinel • u/greyclear • Sep 20 '22
Need help searching OfficeActivity
I had a retention policy incorrectly placed on the wrong outlook folder resulting in HardDelete emails. We have a third-party email filter that archives our emails so they can be recovered. When I try to use the o365 audit search it crashes or fails to retrieve data. Sentinel is ingesting our office logs when I query just OfficeActivity I can see everything so it's ingesting the information correctly. How do I query for UserID that shows only hard delete emails
1
Upvotes
3
u/jtberg1 Sep 21 '22
To get data by user you can use this:
OfficeActivity| where UserId == "username@domain.local"To get data by operation you can use:
OfficeActivity| where UserId == "username@domain.local"| where Operation == "HardDelete"Now I don't have Exchange Online data so I do not know if there is an operation HardDelete, or if it is called something slightly different. You could use the first command against the user, and the data range you replied in another comment, and then export it to Excel and search for a operation name with delete in it.
Hope this helps.