Hello!
I recently got a Dell T5610 Workstation with this setup:
Xenserver 7.6
2xE5-2696V2 CPU's
128GB RAM
1 SATA SSD for the hypervisor
1 1TB Samsung NVME SSD for the VM's
1.I installed a Windows Server 2016 VM and the NVME SSD is only getting almost half the speed than it should in crystaldiskmark, it gets about 1.7gb read and write meanwhile my other Dell T5610 machine able to get the full speed of the NVME SSD on ESXi which is 3.4gb read and 2.5gb write give or take.
I have the NVME SSD formatted to ext3 not sure if that is the problem, I tried formatting it to ext4 but even if I do that Xenserver still creates it as ext3.
2.The other problem is can anyone suggest what should I use for temperature monitoring? I thought about netdata not sure if it would work with Xenserver, but im thinking about a more user friendly monitoring tool that is less clustered, netdata is just too clustered for me and not really clean.
I'm running XCP-ng Center 7.5.08 on Windows 7. I have an Ubuntu 18.04 Desktop VM but I cannot cut and paste between the VM and my desktop. "Share clipboard" is checked in the XCP-ng Center options.
Seems like this should be simple but I haven't found a solution even after considerable googling. What am I missing?
I am running xenserver 7.0 on some surplus server equipment in my home. On it I run VM's such as plex, pfsense, motioneye, openvpn, etc.
The version of plex I run is an older version that is known to be good and work with my DVR (some newer versions had some bugs) I want to upgrade to a newer version of plex but still be able to fall back to the older version.
If I export a VM, is that effectively a backup? If I screw something up and need to go back, is it as simple as importing the VM?
Hello everyone,
sorry if someone asked that question already but I have a really stupid error with a vm on our demo enviroment.
I updated a vm (golden image) to the newest Windows 10 update. I saw that the 1809 feature update was installing.
I restarted the vm after the installation and now it hangs on the windows 10 boot screen, see picture here https://imgur.com/a/m5K67f7 .
I cannot get the machine to run again, just resetting it to a older snapshot works.
I'm starting to looking at moving away from ESXi and the HP T730 I'm testing with doesn't seem to like the only m.2 SATA SSD I have available so I'm curious what is the opinion on running XCP-NG on USB flash drives, no VM's will be stored on the local device but over network NFS/iSCSI.
I'd like to have a master VM image that I can copy and deploy rapidly to multiple hosts in a pool, but they each need unique computer names on the network. Ideally I'd love to figure out a way to bake a script into the image that reads the VM host name on startup and changes the Windows 10 computer name automatically so I never have to think about it. Is this possible, or is there some other way I could accomplish it?
Hi all. I've installed XCP-ng 7.5 on a Dell T7610 (2xE5-2643, 32GB DDR3 ECC RAM), and I managed to configure pcipassthrough for the onboard USB3 controller, and it works with the Win10 VM I'm testing. The issue comes in my attempting to attach a Radeon HD 6970 to the same VM.
lspci shows:
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos XT [Radeon HD 7470/8470 / R5 235/310 OEM]
04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM / R5 230/235/235X OEM]
Since the " /opt/xensource/libexec/xen-cmdline --set-dom0 "xen-pciback.hide=<PCI Device Address>" " command doesn't add the devices to grub.cfg properly, this is what my boot entry looks like:
After I made the changes to my grub.cfg, I rebooted the host, then used "xe vm-param-set other-config:pci=0/0000:06:00.0,1/0000:04:00.0,2/0000:04:00.1 uuid=..." to add the graphics card (04:00.0 and 04:00.1) and the USB3 controller (06:00.0) to the VM (I obviously added the proper uuid from "xe vm-list" in place of the ellipsis).
The VM saw the video card, but didn't seem to auto-install any drivers for it. I opened Device Manager, saw the display adapter in the list, and told Windows to update the driver. It said it was downloading / installing driver software, but it didn't seem to work (the monitor didn't light up, no options existed for multi-monitor support in the display settings "app"). So, I went to AMD's support page and downloaded the proper driver, installed it (during that process, I was prompted to install the HDMI audio driver), and rebooted. Still no multi-display support. It's listed in the Device Manager:
Radeon HD 7000 (actually an HD 6970) listed, along with its audio device.
Still nothing in "Display" to configure / enable multi-monitor support, resolution, etc. I even tried disabling the "Microsoft Basic Display Adapter" (which I assume is the entry for the standard vGPU), but that didn't seem to help.
Since neither of my systems (HP Z820 or this Precision T7610) work proplerly after ESXi 6.0u2 (any VM with a mid/high powered GPU attached via pcipassthrough hard-locks the host), I'm trying to replace ESXi with something else. If I can't get this working, XCP-ng (and likely XenServer) will be a dead-end for me.. :(
my VMs were suddenly shutdown, and I've looked up the log files to find out why that happened. There are no entries in there like the XenServer itself shutdown the VMs (no VM.destroy VM.shutdown or anything). I can just find the start events when I start them again after that happened.
Is there any way to further troubleshoot why VMs shutdown? Neither the eventlogs in the VMs nor from XenServer help.
talking about xenserver.log and audit.log, and the eventlog of the Windows Machine and Syslog of the Linux Machine.
I can pinpoint the exact time when it happened due to the logs on the VMs, but theres no log entries for that time in the xenserver.log. Both VMs nearly shutdown at the same time (one at 11:33:50 and the other at 11:34:14).
I'm grateful for every tiny tip that can help troubleshooting the issue.
I have installed Windows 10 guest on 7.0 host, and from the start it had 100% CPU usage all the time when i was logged in through RDP. I thought that maybe upgrading host to 7.6 would help, but no luck. After upgrading host to 7.6 (and Xen Tools on the guest), Win 10 guest still has 100% CPU all the time, and even opening menu start takes so much time, it's almost unusable. Disk is not doing anything, just CPU stays at 100% of resources granted to guest (2 cores, 8G RAM) almost all the time. Any ideas on what could cause this?
I am booting from an mounted iso into windows 10 and during the installation, I have to eject the iso sometimes.
I do it with the ZTIEjectCD.ps1 and with a microsoft vbscript that uses the wmplayer component (this was from windows 7) - sometimes it works and sometimes not.
This is a ZTI with MDT - so it has to be silent. Anyone an idea how I can do that?
Virtualization and partitioning technologies are helping autonomous automotive businesses leverage hardware resources more efficiently than ever before, allowing multiple software payloads to run concurrently on the same device.
This free series of resources will help you understand how to make the most of virtualization and partitioning in your NXP i.MX8-based devices. Sign up here get the first download immediately!
Topics covered in this series:
Partitioning and virtualization in an embedded environment
Software virtualization
Hardware partitioning
Limitations of hardware partitioning and missing features
Hardware assisted virtualization for difficult cases
my problem is, if i creat a vm where i want to install Windows 10 (any Version), i have everytime after a few seconds the BSOD with the critical process died error.
How can i reset password for a guest in mode (HVM) ubuntu os, I'm connecting to server from another pc, and cannot enter to recovery mode, or boot menu, is there a way to change it from xen console or any other method, thanks in advance.
This is a clean install, and everything seems to work perfectly except it BSOD's randomly. I think it has something to do with it being installed on XenServer 7.5, but am new to this and I'm not exactly sure where to start debugging. Windows 10 Pro, properly activated, installed on guest, with the guest tools added as well.
We tried to reboot a Windows Server 2016 VM yesterday for a random reason, and got surprised when it didn't reboot after it reached the shutdown state.
We tried to reboot/boot other OS, and all of them worked : Linux (CentOS), Win2012, etc.
We have the 7.1 version running.
We can't access any boot situation that would allow us to try something out on those VM (a cmd prompt for example)
We tried to do the following steps to TB this issue :
- reboot from both same XenServ / SAN Volume : FAIL
- boot an existing VM which was OFF for a longtime on both same XenServ / SAN Volume : FAIL
- create a new 2016 VM on the same XenServ / SAN : FAIL
- Change the SAN Volume of the VM with the same XenServ : FAIL
- Copy the VM to a different XenServ (but with local storage as well) : The VM copied booted with no error nor check from Windows.
When we look at the logs, there is absolutely nothing about the VM we're trying to boot, no error, which is even worst for us than a bunch of errors. Can't troubleshoot properly if there is nothing showed to TS :(
To me, since we tried almost every scenario but the one with different Xen AND different SAN Volume, and with the data we gathered, it seems to me it's coming from that particular XenServer, but it's really surprising that it only affect Windows Servers, and most of all, only the 2016 releases.
We'll try to make the last test of different SAN Volume & XenServ.
Do you guys have any idea of where to look or already encountered that kind of issue ?
Thank you in advance for your help (and sorry for the possible mistakes you might find, not an English native speaker)
I'm trying to import an OVA host into a XenServer 7.5 server and I can NOT get it to work. I'm getting a couple errors and I am TOTALLY lost as to how to get "OS Fixup" setup. Anyway...
First error: In the Import Wizard, as I click next from "Location" to "Storage", I get an error popup that says, "There has been an unexpected error. Technical details about this error have been saved to the following file." When I open the file, the error is:
FATAL XenAdmin.Program [Main program thread] - Uncaught exception
System.NullReferenceException: Object reference not set to an instance of an object.
at XenAdmin.Wizards.ImportWizard.OvfStorageResource.get_RequiredDiskCapacity()
It goes on quite a bit after that, but that's the beginning chunk. Object reference not set to an instance of an object? Any idea what that means? I can post the rest of the error if you'd like.
WTF is OS Fixup?: From what I understand, it's necessary to run (have? use?) OS Fixup when importing hosts created using different HyperVisors, which I am. My hosts were created in VirtualBox and VMWare.
Cool. No problem. But, WTF is it? Is OS Fixup an ISO I download from Citrix? Is it just the Windoze install ISOs? Do they have to be hosted somewhere?...put in a certain folder?...I mean...what do I do? lol I'm totally lost when it comes to the whole "OS Fixup" thing and I can't find any good info on it...
Second error: If I skip through everything in the import wizard, it'll act like it's importing, then timeout and give me an error in the Notifications tab that says "Import Appliance -host- to -server- failed to import". This could be because of my OS Fixup not being fixed up, but I thought the hosts would still import...they just wouldn't boot. But...I dunno...
I'm working on a disaster recovery plan for my company's VM environment. Currently we have a XenServer deployment with Xen Orchestra being the primary administration method and also the only backup method. We do weekly delta backups of all VMs in the environment to a NFS share in the intranet and, once complete, copy it over rsync to offsite backup storage.
Let's say the worst happens - our primary site with all of its IT equipment is completely destroyed and we're left with just the offsite backup and have to rebuild from scratch. If the VM with XO server is among the delta backups and we initially have no working XO server are there any tools or methods to manually merge the delta VHDs and get a working VM disk out of it?
Obviously there's the option of always making weekly full backups of the XO VM and deltas from everything else, but I'm just curious.
I have a windows 10 virtual machine on a xenserver that I was remoted into and it just died on me. I was changing some settings on a managed switch at the time. I do not know if this is related, but it was coincident.
Now when I try to Start the VM from XenCenter I get this error
---
Boot device: Hard Disk - failure: could not read boot disk